Lerppujen lukeminen XA1541-kaapelilla

Saku-foorumi » Vapaa sana » Lerppujen lukeminen XA1541-kaapelilla « Edellinen Seuraava »

Kirjoittaja Viesti
 

Janne Peräaho
Käyttäjätunnus: jakp

Rekisteröity: 10-2009
Perjantaina, 24. heinäkuuta, 2015 - klo 20.01:   
Moi

Onko kenelläkään kokemusta lerppujen lukemisesta PC:llä XA1541-kaapelin ja Commodoren lerppuaseman avulla?

Olen kytkenyt kyseisellä kaapelilla Commodore 1571 -lerppuaseman Windows XP -peeceehen ja asentanut OpenCBM-ohjelmapaketin, jolla aseman käyttö pitäisi onnistua.

Asema ei kuitenkaan reagoi mihinkään muuhun kuin OpenCBM:n cbmctrl-ohjelmalla lähetettyyn resetointikomentoon (merkkivalo syttyy ja asema pyöräyttää lerppua). Kaikista muista komennoista cbmctrl palauttaa virheilmoituksen "The system cannot find the file specified."

 

flux
Käyttäjätunnus: flux

Rekisteröity: 2-2010
Perjantaina, 24. heinäkuuta, 2015 - klo 20.16:   
Itse olen käyttänyt 486 konetta, jossa isa-väylässä multi-io kortti, sekä x1541 piuhaa, jossa ei ole yhtään komponenttia. Käyttiksenä msdos 6.22. Softana dos-pohjainen star commander, joka muistuttaa kovasti norton commanderia.

Bat85 diodit ovat olleet laatikossa tulevaa xe1541 muutosprojektia varten.

Muistaakseni x/xe1541 toimii thinkpad T4x läppärissä hyvin, kun käynnistää esim boottaavalta usb tikulta msdossiin ja star commander. Uudemmissa thinkpadeissa ei enää ole printteriporttia ilman porttitoistinta.

 

flux
Käyttäjätunnus: flux

Rekisteröity: 2-2010
Perjantaina, 24. heinäkuuta, 2015 - klo 20.25:   
Kysyjälle jäi vastaamatta, että onhan biossista kokeiltu lpt-portin eri moodit. spp, epp, ecp.

 

Janne Peräaho
Käyttäjätunnus: jakp

Rekisteröity: 10-2009
Lauantaina, 25. heinäkuuta, 2015 - klo 14.20:   
Joo, kokeilin kaikkia kolmea.

Testasin kaapelia Star Commanderilla FreeDOSissa enkä saanut mitään eloa lerppuasemaan.

Avasin kaapelin ja vertasin sen kytkentää tähän Building the XA1541 Serial Cable. Se oli muuten samanlainen, paitsi DB25-liittimen pinnejä 18-24 ei ollut kytketty maahan eikä pinneissä 17, 16, 14 ja 1 ollut vastuksia.

Äh. Ostin kaapelin juuri siksi, että ei tarvitsisi omilla puutteellisilla taidoilla alkaa värkkäämään kaapelin kanssa :-(

 

flux
Käyttäjätunnus: flux

Rekisteröity: 2-2010
Sunnuntaina, 26. heinäkuuta, 2015 - klo 13.30:   
Varmaankin kytketty vain 25 maahan. Yksi piisaa, samaa maata kaikki ovat.

17, 16, 14 ja 1 kytketty trankkuihin ilman vastusta, vaikka speksien mukaan kuuluisi olla 4.7k vastukset. Ei ihme, jos ei toimi.

Kokeile eri konetta ja mahdollisimman vanhaa. Desktopissa max pentium 4 ja läppäreissä max pentium m.

Tarkista osoite ja keskeytys biossista ja siirtosoftasta. Ammoisina 486 aikoina lpt1 oli multi-io kortissa vakiona 378.

 

Janne Peräaho
Käyttäjätunnus: jakp

Rekisteröity: 10-2009
Torstaina, 20. elokuuta, 2015 - klo 2.15:   
Sain hankittua puuttuvat vastukset ja juotin ne kaapeliin ohjeen mukaan. Lerppuasema ei kuitenkaan toimi yhtään paremmin tuolla muutoksella.

Ongelma taitaa nyt olla transistoreissa, joitten merkinnöistä en ymmärrä mitään. Kaapelin transistoreissa lukee S170 PH56, kun taas netissä olevassa rakennusohjeessa ohjeistetaan käyttämään transistoreita BSV52.

Testikoneena oli Pentium III -pöytäkone.

 

virgo
Käyttäjätunnus: virgo

Rekisteröity: 10-2009
Torstaina, 20. elokuuta, 2015 - klo 22.39:   
osaakohan se XP hoitaa tuota printteri väylää oikein
parhaiten toimii dossilla ja vanhalla raudalla
omani on 75Mhz pena ja dossilla pyörii

 

innos
Käyttäjätunnus: innos

Rekisteröity: 1-2010
Tiistaina, 12. tammikuuta, 2016 - klo 20.23:   
Köh.. Amigan seriaaliportti hoitaa homman luotettavammin ja helpommin.

 

innos
Käyttäjätunnus: innos

Rekisteröity: 1-2010
Tiistaina, 12. tammikuuta, 2016 - klo 20.27:   
Helpotuslinkki unohtui: http://aminet.net/package/misc/emu/Easy1541

 

Joni Valtanen
Käyttäjätunnus: jvaltane

Rekisteröity: 7-2010
Keskiviikkona, 13. tammikuuta, 2016 - klo 14.16:   
Eiköhän tuo Easy1541:kin rinnnakkaisporttiin kytketä. Kuten innos mainitsi niin toimii hyvin. Itselläni oli vuosia käytössä.

Jos PC:hen kaapelia pohtii, niin nykyisin joku USB-kaapeli olisi paras. Vaikka XU1541 http://spiro.trikaliotis.net/xu1541. On toiminut kuuleman mukaan moiset hyvin.

XA1541 kaapelia käytin WinXP:llä ja Linux:lla. Toimi hienosti kunhan pisti BIOS:sta rinnakkaisportin asetukset kohdilleen.

Itsellä on vielä extrana vanha akuton IBM thinkpad läppäri, jossa 1541-kaapeleille sopiva rinnakkaisportti ja FreeDOS. X1541-kaapelin kanssa testailin sitä. Ajattelin kokeilla 64HD:tä, mutta huomasin että se olikin kaupallinen, joten homma jäi sikseen. Tosin Amigalle saa Emul1541:sen joka hoitaa homman.

Lisää viestisi tähän
Viestisi:
Käyttäjätunnus: Postitus informaatiota:
Tämä on yksityinen keskustelupalsta. Vain rekisteröidyt käyttäjät ja moderaattorit voivat postittaa tänne.
Salasana:
valinnat: Aktivoi URL:t automaattisesti tässä viestissä
Toimenpide: